弃婴形态选股公式

帮我写个选股公式一根中阴线或大阴线之后,跟着一串小阳小阴横盘。最好是横盘。非常感谢

横盘选股,我可以写

求一个横盘刚刚突破选股公式

DIFF:=EMA(EMA(CLOSE,12)-EMA(CLOSE,26),5);
DEA:=EMA(DIFF,9);
A1:=DIFF;
A2:=DEA;
MACDOK:=CROSS(DIFF,DEA);
ZHANGFU:=(H-REF(C,1))/REF(C,1)*100;
MA25:=MA(C,25);
MA60:=MA(C,60);
MA90:=MA(C,90);
MA120:=MA(C,120);
A3:= (MA25-MA60)/MA60*100;
A4:= (MA25-MA90)/MA90*100;
A5:= (MA25-MA120)/MA120*100;
A6:=IF(C>=O,C,O);
A7:=(H-A6)/A6*100;
A8:=(H-REF(C,10))/REF(C,10)*100;
A9:=(H-REF(C,11))/REF(C,11)*100;
A10:=(H-REF(C,12))/REF(C,12)*100;
A11:=(H-REF(C,13))/REF(C,13)*100;
A12:=(H-REF(C,14))/REF(C,14)*100;
A13:=(H-REF(C,15))/REF(C,15)*100;
A14:=(H-REF(C,16))/REF(C,16)*100;
A15:=(H-REF(C,17))/REF(C,17)*100;
A16:=(H-REF(C,18))/REF(C,18)*100;
A17:=(H-REF(C,19))/REF(C,19)*100;
A18:=(H-REF(C,20))/REF(C,20)*100;
A19:=(H-REF(C,21))/REF(C,21)*100;
A20:=100;
A21:=A8<A20 AND A9<A20 AND A10<A20 AND A11<A20 AND A12<A20 AND A13<A20
AND A14<A20 AND A15<A20 AND A16<A20 AND A17<A20 AND A18<A20 AND A19<A20;
B1:=30;
B2:=(L-REF(H,6))/REF(H,6)*100;
B3:=(L-REF(H,7))/REF(H,7)*100;
B4:=(L-REF(H,8))/REF(H,8)*100;
B5:=(L-REF(H,9))/REF(H,9)*100;
B6:=(L-REF(H,10))/REF(H,10)*100;
B7:=(L-REF(H,11))/REF(H,11)*100;
B8:=(L-REF(H,12))/REF(H,12)*100;
B9:=(L-REF(H,13))/REF(H,13)*100;
B10:=(L-REF(H,14))/REF(H,14)*100;
B11:=(L-REF(H,15))/REF(H,15)*100;
B12:=(L-REF(H,16))/REF(H,16)*100;
B13:=(L-REF(H,17))/REF(H,17)*100;
B14:=(L-REF(H,18))/REF(H,18)*100;
B15:=(L-REF(H,19))/REF(H,19)*100;
B16:=(L-REF(H,20))/REF(H,20)*100;
B17:=(L-REF(H,21))/REF(H,21)*100;
B18:=B2<B1 AND B3<B1 AND B4<B1 AND B5<B1 AND B6<B1 AND B7<B1 AND B8<B1 AND B9<B1 AND
B10<B1 AND B11<B1 AND B12<B1 AND B13<B1 AND B14<B1 AND B15<B1 AND B16<B1 AND B17<B1;
C1:=(H-REF(C,1))/REF(C,1)*100;
C4:=COUNT(C1>4.5,80 )>=5 AND COUNT(C1>3,60 )>=10;
D1:=MACDOK AND COUNT(MA60>REF(MA60,1),60)>=20 AND A3<10 AND C4 AND COUNT(A21,60)>=60 AND COUNT(B18,20)>=20 AND ZHANGFU>3.5 AND L<MA25 AND H >MA25;
D2:=COUNT(MA90>REF(MA90,1),90)>=30 AND A4<10 AND C4 AND COUNT(A21,90)>=90 AND COUNT(B18,20)>=20 AND ZHANGFU>3.5 AND L<MA25 AND H >MA25;
D3:=COUNT(MA120>REF(MA120,1),120)>=30 AND A5<10 AND C4 AND COUNT(A21,120)>=120 AND COUNT(B18,20)>=20 AND ZHANGFU>3.5 AND L<MA25 AND H >MA25;
横盘突破:=D1 OR D2 OR D3 AND C>O;
买入:横盘突破;
股票公式专家团为你解答,希望能帮到你,祝投资顺利。

求下列形态选股公式(通达信):

XG:(REF(C,3)>REF(C,4) AND REF(V,3)>REF(V,4)) AND DOWNNDAY(CLOSE,3) AND DOWNNDAY(VOL,3) AND EXIST(CLOSE/REF(CLOSE,1)>0.9,3);

请高手将这个通达信该成选股公式,选出出现“漂亮版”的股票

J1:=MA(C,5);
J2:=MA(C,10);
J3:=MA(C,30);
J4:=MA(C,60);
J5:=MA(C,120);
时间:=BARSLAST((((CROSS(J2,J1) AND (J2 > J3)) AND (J3 > J4)) AND (J4 > J5)));
前高:=REF(HHV(C,200),时间);
PT:=REFDATE(前高,DATE);
ZF:=(((C - REF(C,1)) / REF(C,1)) * 100);
S1:=(((L > REF(H,1)) OR (ZF > 9.6)) OR (REF(ZF,1) > 9.6));
强势预选:=((CROSS(C,PT) AND (S1 > 0)) * 8);
漂亮2:=(((((((((((SMA((MAX((C - (REF(C,1))),0)),24,1)) / (SMA(ABS((C - (REF(C,1)))),24,1))) * 100) > 65) AND (((((EMA(C,5)) * 7) + ((EMA(C,10)) * 3)) / 10) > (EMA(C,13)))) AND ((EMA(C,13)) > (EMA(C,55)))) AND (((MA(C,26)) + (2 * (STD(C,26)))) > (REF(((MA(C,26)) + (2 * (STD(C,26)))),1)))) AND (C > (EMA((((H + L) + C) / 3),13)))) AND (DYNAINFO(7) > 0)) AND ((MA(C,5)) > (MA(C,10)))) AND ((CROSS((HHV(C,5)),((MA(H,10)) * (1 + (5 / 100))))) AND ((((C - (REF(C,1))) / (REF(C,1))) * 100) > 7.5))) ;
漂亮板:强势预选 AND 漂亮2;

能不能把这公式做成能选出“机构介入”的选股公式?

{JGJR-1}
VAR14:=TROUGHBARS(3,15,1)<10;
VAR15:=IF(VAR14=1,50,0);
底部:=IF(VAR15=50,10,0);
机构介入:底部/20;
{JGJR-2}
VAR1:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR2:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR3:=BARSCOUNT(CLOSE);
VAR4:=VAR1<20 AND VAR2<23 AND VAR3>35;
VAR5:=VAR4 AND COUNT(VAR4,1)=1;
VAR6:=EMA(CLOSE,21)-EMA(CLOSE,8);
VAR7:=EMA(VAR6,5);
VAR8:=TROUGHBARS(3,6,1)<4 AND CROSS(VAR6,VAR7);
VAR9:=(HIGH+LOW+CLOSE)/3;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=(VAR9-MA(VAR9,14))/(0.015*AVEDEV(VAR9,14));
见底:VAR10;
没办法的事,公式设计含有未来函数。{个人看法,仅供参考}

请老师帮编写以下指标公式“机构加仓”为选股公式.

这个好像很难哦